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This is an open access presentation under the CC BY license (http://creativecommons.org/licenses/by/4.0/)
Please ensure any existing acknowledgements / references of sources are preserved in any reuse.

Point cloud viewing, registration and segmentation in Cloud Compare: Tutorial instructions
[bookmark: _GoBack]Hopefully you have installed CloudCompare on your laptops. If not, please download and install the latest stable release from: https://www.danielgm.net/cc/ . These instructions were developed for version 2.12.3 Kyiv.
Note, the instructions were developed on a Windows machine. If you have a Mac, some instructions requiring ‘right click’ etc, may need adapting. Useful keyboard shortcuts for Cloudcompare can be found here if you have problems: https://www.cloudcompare.org/doc/wiki/index.php/Shortcuts 
Section 1: Importing scans into CloudCompare and changing display properties
Go to File> Open and navigate to the unregistered point cloud files, changing the drop-down file type to ‘RBD Pointcloud File (.rbdx)
Open the first .rbdx file from scan position 1. Leave the import settings as defaults – this will import the x,y,z locations of points, along with their reflectance, amplitude and deviation as scalar values and click ok. Note that other fields can also be imported, such as scan line index, timestamps etc. The available fields will differ for different TLS scanners.
You should now see a scan loaded in the main CC viewer. Highlight the scan name in the DB tree window
[image: ]
Then under properties go to ‘Scalar Fields’ and in the ‘Active’ drop down switch between riegl.reflectance and riegl.amplitude – the changes in colour in the display show the influence of range from scanner on the raw intensity (riegl.amplitude) and the impact of the on-board range corrections (riegl.reflectance, although note this is still sensitive to the amount of material in the laser beam and local incidence angle of the beam). You should see that the values are lower further from the scanner (centre point of scan) in the ‘riegl.amplitude’, but not ‘riegl.reflectance’.
[image: ]
Note, you can also change the colour scale in the options below (change the current colour scheme to your favoured option, although the default ‘blue>green>yellow>red’ is a reasonable choice). If you tick ‘visible’ this will add a colour scale bar to the main viewer, with a distribution / histogram of data values alongside, showing the intensity / reflectance of the data in the scan. If there is limited variation in the colours visible, you can adjust (lower) the ‘saturation’ value in the SF display parameters based on the displayed histogram to give more contrast.
You can also experiment with different point sizes – ‘Cloud’> Point Size. ‘1’ or ‘2’ are usually sensible choices.
Now, set the scalar parameter displayed back to calibrated reflectance and have a look at the first scan point cloud. To rotate the point cloud, left click on the point cloud and move using your mouse / touchpad. To zoom, use the scroll wheel / two fingers on the touchpad. To move the view horizontally / vertically on your screen (to re-centre) right click and drag.
[image: ]
[image: ]You can also use the shortcuts on the left to move to viewing the point cloud from particular perspectives. This is particularly useful if you want to return quickly to an overhead /cross-section view.
Have a look at this single scan point cloud. If you view a cross-section / side-on view, you should be easily able to view the trees. If you zoom in on branches and trunks, you may see the ‘reflectance’ varies from centre to edge of the trunk. This is due to the influence of both incidence angle and at the very edge of the trunks, partial hits occupying only part of the scanner footprint, both of which lower the intensity of the return. 
[image: ]
You can also change the rotation centre by double left-clicking on a point in the scan – the scan will then rotate around this point, which can be useful to examine a certain area of a scan.
Have a good look at the single scan to get a feel for the type of information contained. However, you will likely notice that there is a lot of occlusion – areas where there is no data as these regions were behind other objects from this scan position. You will see you can also only see one side of each tree trunk.
Segmenting a sub-section of the point cloud
To see this more clearly, we will look in more detail at just a sub-section of the scan. Return to an overhead view of the scan. We will then use the segment tool to sub-set the scan. 
First, copy the original scan in the viewer by highlighting the scan name, then going to ‘edit>Clone’ [image: ]. This produces a fresh copy we can segment without losing data from the original scan (note you can always also re-import the original scan as long as you don’t over-write when saving / exporting your segmented version). Now untick the original scan and highlight the cloned scan name.
 Then locate the ‘Segment’ tool in the bar at the top (scissor icon [image: ]). Click on this tool, and then draw a polygon over a small area of the point cloud that is of interest (it doesn’t matter where too much at this stage, but keep it fairly small and include some trees). Left click to specify vertices and right click to complete the polygon when done. You should see a  box / shape displayed.
The segment tool provides options to cut out the areas you have specified (remove it from the point cloud, segment out - [image: ] ) or to keep only this section (segment in [image: ]). We will do the latter, so click the [image: ] symbol in the tool bar that appears in the right of the viewer window. Then click the green tick.
A new point cloud will now be present in the list in the ‘DB Tree’ window which contains just the segment you extracted. Untick the ‘remaining’ point cloud and you will see just the segmented section displayed, allowing you to view it more easily.
Note, the original cloud is also retained unchanged, so if you want to try again, highlight the segmented cloud, right click and choose ‘delete’ then repeat the above steps (from cloning!). You can also export the segmented point cloud / save it by right clicking on the point cloud name
We will use this tool again to segment individual trees later on.
[image: ]
-------------------------------------------------
Section 2: Scan registration in CloudCompare
Now you have a feel for some of the basic functions in CC, we will look at how we can register scans together in this software.
To avoid confusion at this point, I suggest you remove your cloned and segmented point clouds from the viewer at this stage (right click on scan name and ‘delete’). However, leave the original import of scan position 1 in the viewer.
As you did with the first scan position, now import the .rbdx file for scan position 2. These two scans are not registered to each other at this stage but do overlap in the area they cover. 
CloudCompare has a number of different methods to register scans, mostly found under ‘Tools > Registration’:
· [image: ]  Manual translate / rotate 
· [image: ]  Align (point pairs picking) – selecting 3 or more known common points in the two scans, ideally known targets. 
· [image: ]  Fine registration (ICP) – an automated fine registration, best used once the scans are approximately registered
· A ‘sandbox’ research tool (Tools > Sand box’) designed to auto-align point clouds. Still in development and may crash the software. This tool can be tried if you are ‘feeling lucky’ – it may do something useful in some circumstances, but probably isn’t currently the best way to go in general.
Here, we will combine two of these tools – align, to provide a coarse (though potentially pretty good) registration, and then ICP fine registration.
To start with, we will clone both of our scans to make copies. In turn, use the clone ([image: ]) tool to create a copy of each scan. Double-click on the point cloud name for each clone and you can rename these if it makes it easier, but do ensure you know which point cloud belongs to each original scan file. Untick the original imported scan point clouds for not so they are not displayed.
In one of the clone point clouds (either scan position) go to Scalar Fields properties and change the colour scale to ‘greyscale’ so you can distinguish the points belonging to each scan. You will see they are very overlapping at present as the centre of origin in CC will be the scanner position in the centre of each scan. 
When viewing large forest TLS datasets, visually identifying targets / reflectors or other recognisable and distinct features present in both point clouds and selecting a clear point located on them can be difficult, due to the complex canopy, understorey etc and the size of point clouds. We will therefore begin the registration process by segmenting just an area of each scan that is common to both and includes at least 3 (ideally 4) targets / recognisable features. Deselect the second scan position in the DB Tree to view just scan position 1. We will treat this as the reference scan and align scan 2 to this. Rotate and zoom to identify the targets set up in the field if you are able or compare the scans to identify areas that appear common to both. Viewing from an over-head perspective, use the segment tool [image: ], as above, to segment an area of the first scan, using a ‘rectangular region’ to use in the registration process, retaining the section in your rectangle (segment in  [image: ]).  Now repeat this process with scan position 2, selecting and segmenting the region of the scan corresponding to the same area of forest.
[image: ]
[image: ]If you can now visualise and select the targets in your two scans easily, you can skip this next step. If not, once you have two smaller regions of forest to work with, you can simplify the scan further by taking a horizontal cross-section of the scan, including the targets and tree trunks, but excluding upper canopy and ground. Note, this may be less effective if there is complex topography in your scans. Switch to a side-on view of scan position 1 (e.g. ) and using the segment tool again, draw a rectangle above ground level and below the canopy (but including any targets), covering the full width of the scan segment, resulting in a vertical slice of the scan being retained. Repeat for scan position 2, ensuring you choose close to the same height to segment. Remember to untick the ‘remaining’ point clouds to remove them from the viewer display.
[image: ]    [image: ]

Examine both point clouds and identify target locations / alternatively clear features present in both scans where you can identify a common point with a good level of precision. Now select both segmented scans in the DB Tree (hold control + click on the point cloud names of both). Next, click on the Align (point pairs picking) tool [image: ] and in the interface for ‘Entity selector’, select the scan you wish to align (it isn’t too critical here which, but for now we will use scan position 2 as the scan to be aligned, so select this one). 
[image: ]
You will now see the alignment tool in the right of the viewer. You may need to reposition the scans so you can still see them on the left.
Deselect the ‘Show ‘to align’ entities’ check box and select the ‘show reference entities’ one. Make sure the viewer now displays the point cloud you want to align the other scan to (scan position 1).
Now zoom in the viewer to a target / identifiable point in the reference scan. Click on a target point in the viewer which will be used in the registration. Click yes if asked to compute octrees.
[image: ]
Then swap the check boxes so you are viewing the ‘align entity’ (scan position 2 segment). Click on a point that as closely as possible corresponds to the one you chose in scan position 1 (the reference). You should now have matching points selected in each point cloud and the co-ordinates in the align tool window as below.
[image: ]
You now need to repeat this to select at least 3 pairs of points, a minimum of 4 ideally for a real application, but 3 will be ok to save time for now. When you are happy with your 3 pairs of points, click the ‘align’ button and inspect the result. If it looks sensible (a good alignment of the two clouds although perhaps not perfect), click the green tick.
[image: ]
You now have coarsely aligned point clouds. Particularly if you have used spherical targets, which CC should recognise the centre position of automatically when you select them as points, you may have a sufficiently accurate result, depending on your application.
When you click the tick to apply the transformation, you will see a transformation matrix is calculated, which defines how the scan you are aligning is translated and rotated (or scaled if needed) to match the reference. This is also recorded in the point cloud properties so just click ok. 
[image: ]
We can check how closely aligned the point clouds appear to be by calculating the cloud-to-cloud distance (distances to nearest neighbouring point) – which should generally be small where the scans align well. Select (ctrl+click) the two aligned scan segments in the DB tree, then go to ‘Tools > Distances > cloud/cloud dist’ or click [image: ]. In the distance computation tool, make sure the reference (position 1) and compared (position 2) scan are set correctly then click ‘compute’. Once the tool has run, you should see a mean distance and standard deviation displayed in the console at the bottom of the viewer. Close the tool. Now deselect the reference scan in the viewer and have a look at the aligned scan – you should see this is now coloured by cloud-to-cloud distance (check this in the scalar fields (C2C absolute distance) and you can make the scale visible with the check box).
The area of the scan that overlapped with the position 1 subset should show values close to zero, while the distances will increase in areas that did not overlap. If you see large distances within the overlap area, you may need to revisit your ‘align (point pairs picking)’ step. Note, this tool can also be useful for quickly identifying areas of difference between two aligned point clouds (e.g. changes between two dates).
[image: ]
You can now set the scalar field back to riegl.reflectance.
We will now further refine the registration, using the ‘Fine registration (ICP)’ tool. Select the two segmented and coarsely aligned point clouds in the DB Tree and then click [image: ] (or select Fine registration in the tools menu). Be careful to make sure that the cloud you have used as the reference to this point (position 1) is set as the reference in the ‘Clouds registration’ tool window that opens, or click ‘swap’ if not to switch them. Now set the ‘final overlap’ percentage parameter to a rough estimate of how much the aligned point clouds overlap each other (if perfectly aligned). For the example below, I set this as 70%. We will leave other parameters as defaults here, but you can find more detail on these (and other tools!) here: https://www.cloudcompare.org/doc/wiki/index.php/ICP 
[image: ]
Press OK and the tool will run. Once again, a window will display the transformation matrix, which will be added to the existing transformation (from previous coarse align tool) for the aligned scan, to give the total transformation in the ‘properties’. You can also see the RMS error for the alignment. 
[image: ]
In the viewer, have a look at the aligned scans. You should now find they are a close match. However, so far we have only aligned the segments we created. We can now use this transformation to align the full scan for position 2 to that for position 1.
Select the point cloud segment you aligned (position 2) in the DB Tree and go to ‘transformation history’ in the Properties. Click on the export tab and then on ‘clipboard’ to copy the transformation parameters to the clipboard.
Next, you can deselect the segments from being visible in the viewer and display the original full point clouds again (the unaligned .rdbx point clouds). Make fresh ‘clone’ copies of these in case you make a mistake and align these clones - Change the display colour scheme for one to grey so you can see which is which. To do this, now select the position 2 cloud that you wish to align (be careful here that you are keeping the alignment and reference scan positions the same as in the previous steps!). Go to the ‘Edit’ menu and ‘Apply transformation’. In the matrix 4x4 window, click the ‘clipboard’ button to paste in the transformation derived from aligning the segments previously. Then click OK. 
[image: ]
This step can take a few minutes, but the viewer should update and the two scan positions should then appear aligned.
You can then merge the two scans together (‘merge’ tool) if you need to form a single point cloud, which can be exported () – but we won’t do that here as we will now switch to working with the full aligned point cloud from RiScan Pro.
----------------------------------------------------------
Section 3: Manual tree segmentation and classification
Deselect any remaining point clouds in the viewer so they are not displayed. Now go to File>Open and import the .las file produced during the registration demonstration in RiScan Pro, which includes the full scan area from today’s field data collection. 
In opening a .las file you will see a number of parameters you can import. You can leave the standard fields as defaults, but double-check that ‘Intensity’ is checked, which should be used as the scalar field. Then click apply.
Using the tools from the previous section (adjusting the scalar field, colour scheme, point size, zooming and rotating, have a good look at the point cloud. This will give you a good feel for the types of vegetation characteristic that can potentially be extracted from TLS – surface topography, understorey structure, inventory data on trees, tree structure, leaf and canopy properties (e.g. LAI) – this is not an exhaustive list!
Now we will extract an individual tree from the point cloud by segmenting. You used the segment tool [image: ] in the previous section extensively. Clone the imported point cloud. Then based on the ‘clone’, start with an overhead view and segment (segment in  [image: ], and use polygon selection) an area covering, but that is slightly larger than one crown. If you can’t easily identify an individual crown in the overhead view, start with a side-on view instead. This time, don’t click on the ‘tick’ symbol yet! Instead, pause the segmentation ([image: ]) so you can rotate the point cloud to a side-on view (or different view) of the roughly segmented tree. Unpause the segmentation ([image: ]), then draw a further polygon to remove (segment out [image: ]) areas of adjacent crowns / low branches that do not belong to the tree of interest. For now though, leave the ground surface / low understorey in your point cloud – you can remove these through segmentation, but we will use this small point cloud to test the classification tools here also. Inspect the point cloud carefully each time then repeat this process until you have just the tree of interest left. It can take a while! Once you are happy with your final tree segment, click the tick symbol.
[image: ][image: ][image: ]

If you have time (or for later interest)! – point cloud classification in CC
Cloud Compare includes a classification plugin called CANUPO - CAractérisation de NUages de Points, http://nicolas.brodu.net/en/recherche/canupo/
To save computational time, we will classify just the single tree segment here. Clone your single tree to create a new cloud. Here we will try to classify leaf, wood and ground surface layer.
Once again, using the segment tool, segment an area that is representative of each class in turn (‘segment in’) – segment an area of leaves / canopy first, then returning to the ‘remaining’ point cloud being highlighted in the DB Tree, segment again to extract an area of trunk / branch. Repeat for ground. Double-click on the ‘segmented’ point cloud name each time and rename it to the class name. Your table should then look something like this (the ‘remaining’ cloud is set to greyscale here so you can see the samples segmented):
[image: ][image: ] 

Important note: Really you would need to collect several samples for each class to get a good result – we’ll just use one for now to save time. You can collect several segments for a class and then combine them using the ‘merge multiple clouds’ tool [image: ] to a single training sample per class.
We will combine the leaves and woody classes here to a ‘trees’ class, as CANUPO can only classify two classes at once (you could repeat the process sequentially by applying CANUPO to one of the binary classes to obtain finer classes). Select both in the DB Tree then click the merge tool. Generate the scalar field when requested.
[image: ]
Next, go to Plugins > CANUPO>Train classifier, or click   [image: ]. For ‘Class #1’ in the Training interface, select the ground segment. For Class #2, select the merged tree segment. Leave other settings at default and click OK. Click ‘Save’ and save the .prm file, then click ‘Done’.
Now we have trained our classifier to (hopefully!) recognise the ground and tree objects, we will apply it to our whole tree segment. Clone your segmented tree (the version prior to creating separate tree and ground clouds) and highlight this in the DB Tree. Go to ‘Plugins>CANUPO>Classify ([image: ]). For ‘File’, load the .prm file you just saved. Leave other settings at default and click ok. You should now see the classified tree point cloud is coloured by class in the viewer. As in the example below, there may be errors as we did this very roughly. More sophisticated methods are available to distinguish leaf and woody material in TLS data for example, and to identify ground surfaces. However, CANUPO results can also be improved, by using larger training samples / adjusting settings etc.
[image: ]  [image: ]

Note: If you would like to save any of your segmented / aligned point clouds, highlight the point cloud, go to ‘File>Save’ and save each point cloud in your choice of format (e.g. the fairly generic .las format).
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